Back to overview
Downtime

CDN Down

Nov 18 at 11:48am UTC
Affected services
dezgo.com website
API Server

Resolved
Nov 18 at 02:39pm UTC

The incident has now been resolved.

Created
Nov 18 at 11:48am UTC

Due to a worldwide issue with our CDN provider (Cloudflare), our website and API are currently down.

Follow the incident on Cloudflare's page here: https://www.cloudflarestatus.com/