Back to overview
Degraded

SSL Handshake Errors

Mar 29 at 10:00am UTC
Affected services
dezgo.com website (server)

Resolved
Mar 29 at 02:55pm UTC

The root cause of the issue has been identified and successfully resolved.

Created
Mar 29 at 10:00am UTC

Intermittent SSL Handshake Errors have been observed on the website, affecting a subset of pages.

Although a number of these errors were observed on the payment confirmation page, they did not impact the accurate processing of account top-ups. Each top-up transaction was correctly processed and accurately reflected in user balances.